OpenSSL 1.x < 1.0.0e Multiple Vulnerabilities

medium Nessus Plugin ID 56162
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server is affected by multiple SSL-related vulnerabilities.


According to its banner, the remote web server is running a version of OpenSSL 1.x prior to 1.0.0e. It is, therefore, affected by the following vulnerabilities :

- An error exists related to ECDSA signatures and binary curves. The implementation of curves over binary fields could allow a remote, unauthenticated attacker to determine private key material via timing attacks.

- An error exists in the internal certificate verification process that can allow improper acceptance of a certificate revocation list (CRL) if the list's 'nextUpdate' field contains a date in the past. Note that this internal CRL checking is not enabled by default. (CVE-2011-3207)

- An error exists in the code for the ephemeral (EC)DH cipher suites that can allow a remote attacker to crash the process. (CVE-2011-3210)


Upgrade to OpenSSL 1.0.0e or later.

See Also

Plugin Details

Severity: Medium

ID: 56162

File Name: openssl_1_0_0e.nasl

Version: 1.11

Type: remote

Family: Web Servers

Published: 9/12/2011

Updated: 11/15/2018

Dependencies: openssl_version.nasl

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Ease: No known exploits are available

Patch Publication Date: 9/6/2011

Vulnerability Publication Date: 5/17/2011

Reference Information

CVE: CVE-2011-1945, CVE-2011-3207, CVE-2011-3210

BID: 47888, 49469, 49471

CERT: 536044