Apache 2.2 < 2.2.20 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 6021
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is vulnerable to a denial of service attack.

Description

Versions of Apache 2.2 earlier than 2.2.20 are potentially affected by a denial of service vulnerability. Making a series of HTTP requests with overlapping ranges in the Range or Request-Range request headers can result in memory and CPU exhaustion. A remote, unauthenticated attacker could exploit this flaw to make the system unresponsive.

Solution

Upgrade to Apache version 2.2.20 or later or use one of the workarounds in Apache's advisories for CVE-2011-3192.

See Also

http://www.nessus.org/u?404627ec

http://archives.neohapsis.com/archives/fulldisclosure/2011-08/0203.html

http://www.gossamer-threads.com/lists/apache/dev/401638

http://www.nessus.org/u?8c61b13d

https://archive.apache.org/dist/httpd/CHANGES_2.2.20

Plugin Details

Severity: High

ID: 6021

Family: Web Servers

Published: 8/25/2011

Updated: 3/6/2019

Dependencies: 3057

Nessus ID: 55976

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Patch Publication Date: 8/25/2011

Vulnerability Publication Date: 8/19/2011

Reference Information

CVE: CVE-2011-3192

BID: 49303