Apache HTTP Server Byte Range DoS

High Nessus Plugin ID 55976

Synopsis

The web server running on the remote host is affected by a denial of service vulnerability.

Description

The version of Apache HTTP Server running on the remote host is affected by a denial of service vulnerability. Making a series of HTTP requests with overlapping ranges in the Range or Request-Range request headers can result in memory and CPU exhaustion. A remote, unauthenticated attacker could exploit this to make the system unresponsive.

Exploit code is publicly available and attacks have reportedly been observed in the wild.

Solution

Upgrade to Apache httpd 2.2.21 or later. Alternatively, apply one of the workarounds in Apache's advisories for CVE-2011-3192. Version 2.2.20 fixed the issue, but it also introduced a regression.

If the host is running a web server based on Apache httpd, contact the vendor for a fix.

See Also

http://seclists.org/fulldisclosure/2011/Aug/175

http://www.gossamer-threads.com/lists/apache/dev/401638

http://www.nessus.org/u?404627ec

http://httpd.apache.org/security/CVE-2011-3192.txt

http://www.nessus.org/u?1538124a

http://www-01.ibm.com/support/docview.wss?uid=swg24030863

Plugin Details

Severity: High

ID: 55976

File Name: apache_range_dos.nasl

Version: $Revision: 1.31 $

Type: remote

Family: Web Servers

Published: 2011/08/25

Modified: 2016/11/11

Dependencies: 10107, 67257

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/08/25

Vulnerability Publication Date: 2011/08/19

Reference Information

CVE: CVE-2011-3192

BID: 49303

OSVDB: 74721

CERT: 405811

EDB-ID: 17696, 18221