Apache Tomcat 7.0.x < 7.0.20 'jsvc' Information Disclosure

Medium Nessus Network Monitor Plugin ID 6007

Synopsis

The remote web server is affected by an information disclosure vulnerability.

Description

Versions of Tomcat 7.0.x earlier than 7.0.20 are potentially affected by an information disclosure vulnerability. A component that Apache Tomcat relies on called 'jsvc' contains an error in that it does not drop capabilities after starting and can allow access to sensitive files owned by the super user. Note that this vulnerability only affects Linux operating systems and only when the following are true :

- jsvc is compiled with libpcap.

- The '-user' parameter is used

Solution

Upgrade to Apache Tomcat 7.0.20 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.20

Plugin Details

Severity: Medium

ID: 6007

Family: Web Servers

Published: 2011/08/16

Modified: 2016/01/21

Dependencies: 3057

Nessus ID: 55859

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2011/08/11

Vulnerability Publication Date: 2011/08/12

Reference Information

CVE: CVE-2011-2729

BID: 49143