Apache Tomcat 7.x < 7.0.20 'jsvc' Information Disclosure

Medium Nessus Plugin ID 55859

Synopsis

The remote web server is affected by an information disclosure vulnerability.

Description

According to its self-reported version number, the instance of Apache Tomcat 7.x listening on the remote host is prior to 7.0.20. It is, therefore, affected by an information disclosure vulnerability due to a component that Apache Tomcat relies on called 'jsvc' which does not drop capabilities after starting and can allow access to sensitive files owned by the super user.

Note that this vulnerability only affects Linux operating systems and only when the following are true :

- jsvc is compiled with libpcap

- the '-user' parameter is used

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.20 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.20

Plugin Details

Severity: Medium

ID: 55859

File Name: tomcat_7_0_20.nasl

Version: 1.13

Type: remote

Family: Web Servers

Published: 2011/08/16

Updated: 2018/08/03

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2011/08/11

Vulnerability Publication Date: 2011/08/12

Reference Information

CVE: CVE-2011-2729

BID: 49143