Apache Tomcat 7.0.x < 7.0.17 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 5996

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 7.x listening on the remote host is prior to 7.0.17. It is, therefore, affected by the following vulnerabilities:

- An error handling issue exists related to the MemoryUserDatabase that allows user passwords to be disclosed through log files. (CVE-2011-2204)

- If loaded before other web applications, a malicious web application can potentially access or modify the web.xml, context.xml, and TLD files of other web applications on the system. (CVE-2011-2481)

- An input validation error exists that allows a local attacker to either bypass security or carry out denial of service attacks when the APR or NIO connectors are enabled. (CVE-2011-2526)

Note that Nessus Network Monitor has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat 7.0.19 or later. Note that versions 7.0.17 and 7.0.18 are not affected but were never officially released.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.19

Plugin Details

Severity: Medium

ID: 5996

Family: Web Servers

Published: 8/1/2011

Updated: 3/6/2019

Nessus ID: 55759

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.3

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 7/19/2011

Vulnerability Publication Date: 6/27/2011

Reference Information

CVE: CVE-2011-2204, CVE-2011-2526, CVE-2011-2481

BID: 48456, 48667, 49147