Apache Tomcat 7.x < 7.0.17 Multiple Vulnerabilities

high Nessus Plugin ID 55759

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 7.x listening on the remote host is prior to 7.0.17. It is, therefore, affected by the following vulnerabilities :

- An error handling issue exists related to the MemoryUserDatabase that allows user passwords to be disclosed through log files. (CVE-2011-2204)

- If loaded before other web applications, a malicious web application can potentially access or modify the web.xml, context.xml, and TLD files of other web applications on the system. (CVE-2011-2481)

- An input validation error exists that allows a local attacker to either bypass security or carry out denial of service attacks when the APR or NIO connectors are enabled. (CVE-2011-2526)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.19 or later. Note that versions 7.0.17 and 7.0.18 are not affected but were never officially released.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.19

https://www.mail-archive.com/[email protected]/msg00053.html

https://www.mail-archive.com/[email protected]/msg00055.html

Plugin Details

Severity: High

ID: 55759

File Name: tomcat_7_0_19.nasl

Version: 1.20

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 8/3/2011

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: Medium

Base Score: 4.4

Temporal Score: 3.3

Vector: AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2011-2204

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Ease: No known exploits are available

Patch Publication Date: 7/19/2011

Vulnerability Publication Date: 6/27/2011

Reference Information

CVE: CVE-2011-2204, CVE-2011-2481, CVE-2011-2526

BID: 48456, 48667, 49147