Apple iOS < 4.3.4 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5986

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote mobile host is a using a version of Apple iOS earlier than 4.3.4. Such versions are potentially affected by multiple vulnerabilities. Apple iOS 4.3.4 contains security fixes for the following components :

- CoreGraphics

- IOMobileFrameBuffer

Solution

Upgrade to Apple iOS 4.3.4 or later.

See Also

http://support.apple.com/kb/HT4802

http://support.apple.com/kb/HT4803

http://lists.apple.com/archives/Security-announce/2011/Jul/msg00000.html

http://lists.apple.com/archives/Security-announce/2011/Jul/msg00001.html

http://www.appleinsider.com/articles/11/07/06/hackers_release_new_browser_based_ios_jailbreak_based_on_pdf_exploit.html

Plugin Details

Severity: High

ID: 5986

File Name: 5986.prm

Published: 2011/07/15

Modified: 2016/12/09

Dependencies: 8637

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:apple:iphone_os

Patch Publication Date: 2011/07/15

Vulnerability Publication Date: 2010/11/26

Reference Information

CVE: CVE-2010-3855, CVE-2011-0226, CVE-2011-0227

BID: 44214, 48619, 48701

OSVDB: 68704, 73661, 73808