CVE-2010-3855

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Buffer overflow in the ft_var_readpackedpoints function in truetype/ttgxvar.c in FreeType 2.4.3 and earlier allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted TrueType GX font.

References

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=602221

http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=59eb9f8cfe7d1df379a2318316d1f04f80fba54a

http://lists.apple.com/archives/security-announce/2011//Jul/msg00000.html

http://lists.apple.com/archives/security-announce/2011//Jul/msg00001.html

http://lists.apple.com/archives/security-announce/2011//Mar/msg00003.html

http://lists.apple.com/archives/security-announce/2011//Mar/msg00005.html

http://lists.apple.com/archives/security-announce/2011/Mar/msg00006.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-November/050965.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051231.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051251.html

http://secunia.com/advisories/42289

http://secunia.com/advisories/42295

http://secunia.com/advisories/43138

http://secunia.com/advisories/48951

http://support.apple.com/kb/HT4564

http://support.apple.com/kb/HT4565

http://support.apple.com/kb/HT4581

http://support.apple.com/kb/HT4802

http://support.apple.com/kb/HT4803

http://support.avaya.com/css/P8/documents/100122733

http://www.debian.org/security/2011/dsa-2155

http://www.mandriva.com/security/advisories?name=MDVSA-2010:235

http://www.mandriva.com/security/advisories?name=MDVSA-2010:236

http://www.redhat.com/support/errata/RHSA-2010-0889.html

http://www.securityfocus.com/bid/44214

http://www.securitytracker.com/id?1024745

http://www.ubuntu.com/usn/USN-1013-1

http://www.vupen.com/english/advisories/2010/3037

http://www.vupen.com/english/advisories/2011/0246

https://savannah.nongnu.org/bugs/?31310

Details

Source: MITRE

Published: 2010-11-26

Updated: 2021-01-26

Type: CWE-119

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:freetype:freetype:1.3.1:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.0.6:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.0.9:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1.3:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1.4:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1.5:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1.6:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1.7:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1.8:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1.9:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.1.10:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.2.0:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.2.1:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.2.10:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.0:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.1:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.2:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.3:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.4:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.5:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.6:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.7:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.8:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.9:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.10:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.11:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.3.12:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.4.0:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.4.1:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:2.4.2:*:*:*:*:*:*:*

cpe:2.3:a:freetype:freetype:*:*:*:*:*:*:*:* versions up to 2.4.3 (inclusive)

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
75505openSUSE Security Update : freetype2 (openSUSE-SU-2011:0361-1)NessusSuSE Local Security Checks
medium
68142Oracle Linux 4 / 5 / 6 : freetype (ELSA-2010-0889)NessusOracle Linux Local Security Checks
medium
60898Scientific Linux Security Update : freetype on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
medium
57651GLSA-201201-09 : FreeType: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
57197SuSE 10 Security Update : freetype2 (ZYPP Patch Number 7399)NessusSuSE Local Security Checks
medium
5986Apple iOS < 4.3.4 Multiple VulnerabilitiesNessus Network MonitorMobile Devices
high
53723openSUSE Security Update : freetype2 (openSUSE-SU-2011:0361-1)NessusSuSE Local Security Checks
medium
53487SuSE 10 Security Update : freetype2 (ZYPP Patch Number 7366)NessusSuSE Local Security Checks
medium
53313SuSE 11.1 Security Update : freetype2 (SAT Patch Number 4089)NessusSuSE Local Security Checks
medium
52754Mac OS X 10.6.x < 10.6.7 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
52753Mac OS X Multiple Vulnerabilities (Security Update 2011-001)NessusMacOS X Local Security Checks
high
800796Mac OS X 10.6 < 10.6.7 Multiple VulnerabilitiesLog Correlation EngineOperating System Detection
high
5826Mac OS X 10.6 < 10.6.7 Multiple VulnerabilitiesNessus Network MonitorGeneric
critical
5814Apple iOS < 4.3 Multiple VulnerabilitiesNessus Network MonitorMobile Devices
critical
51828Debian DSA-2155-1 : freetype - several vulnerabilitiesNessusDebian Local Security Checks
medium
50808CentOS 4 / 5 : freetype (CESA-2010:0889)NessusCentOS Local Security Checks
medium
50672Fedora 12 : freetype-2.3.11-7.fc12 (2010-17755)NessusFedora Local Security Checks
medium
50670Fedora 13 : freetype-2.3.11-7.fc13 (2010-17728)NessusFedora Local Security Checks
medium
50620RHEL 4 / 5 / 6 : freetype (RHSA-2010:0889)NessusRed Hat Local Security Checks
medium
50619Fedora 14 : freetype-2.4.2-4.fc14 (2010-17742)NessusFedora Local Security Checks
medium
50608Mandriva Linux Security Advisory : freetype2 (MDVSA-2010:236)NessusMandriva Local Security Checks
medium
50491Ubuntu 6.06 LTS / 8.04 LTS / 9.10 / 10.04 LTS / 10.10 : freetype vulnerabilities (USN-1013-1)NessusUbuntu Local Security Checks
high