Flash Player < 10.3.181.26 Code Execution Vulnerability (APSB11-18)

High Nessus Network Monitor Plugin ID 5967

Synopsis

The remote host contains a browser plugin that is affected by a memory corruption vulnerability.

Description

Versions of Flash Player earlier than 10.3.181.26 are potentially affected by a memory corruption vulnerability that could allow an attacker to execute arbitrary code subject to the privileges of the user running the affected application. This issue is reportedly being exploited in the wild in targeted attacks as of June 2011.

Solution

Upgrade to Flash Player 10.3.181.26 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb11-18.html

Plugin Details

Severity: High

ID: 5967

File Name: 5967.prm

Family: Web Clients

Published: 2011/06/06

Modified: 2016/01/19

Dependencies: 5783

Nessus ID: 55140, 55141

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2011/06/05

Vulnerability Publication Date: 2011/06/05

Exploitable With

CANVAS (CANVAS)

Metasploit (Adobe Flash Player AVM Verification Logic Array Indexing Code Execution)

Reference Information

CVE: CVE-2011-2110

BID: 48268

OSVDB: 73007