Flash Player < 10.3.181.26 Multiple Vulnerabilities (APSB11-18)

High Nessus Plugin ID 55140

Synopsis

A browser plugin is affected by a memory corruption vulnerability.

Description

According to its version, the instance of Flash Player installed on the remote Windows host is earlier than 10.3.181.26. This version of Flash Player has a critical vulnerability. By tricking a user on the affected system into opening a specially crafted document with Flash content, an attacker could leverage the vulnerability to execute arbitrary code remotely on the system subject to the user's privileges.

This issue is reportedly being exploited in the wild in targeted attacks as of June 2011.

Solution

Upgrade to Adobe Flash version 10.3.181.26 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb11-18.html

Plugin Details

Severity: High

ID: 55140

File Name: flash_player_apsb11-18.nasl

Version: 1.13

Type: local

Agent: windows

Family: Windows

Published: 2011/06/15

Modified: 2018/07/11

Dependencies: 28211

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/06/14

Vulnerability Publication Date: 2011/06/14

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Adobe Flash Player AVM Verification Logic Array Indexing Code Execution)

Reference Information

CVE: CVE-2011-2110

BID: 48268

EDB-ID: 19295