MySQL Community Server 5.1 < 5.1.52 Multiple Denial of Service Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5928

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

Versions of MySQL Community Server 5.1 earlier than 5.1.52 are potentially affected by multiple vulnerabilities :

- An error exists in the handling of 'EXPLAIN' for a 'SELECT' statement from a derived table which can cause the server to crash. (54488)

- An error exists int he handling of 'EXPLAIN EXTENDED' when used in some prepared statements, which can cause the server to crash. (54494)

- The server does not check the type of values assigned to items of type 'GeometryCollection'. Such assignments can cause the server to crash. (55531)

Solution

Upgrade to MySQL Community Server 5.1.52 or later.

See Also

http://bugs.mysql.com/bug.php?id=54488

http://bugs.mysql.com/bug.php?id=54494

http://bugs.mysql.com/bug.php?id=55531

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-52.html

Plugin Details

Severity: Medium

ID: 5928

File Name: 5928.prm

Family: Database

Published: 2011/05/23

Modified: 2016/01/30

Dependencies: 5003

Nessus ID: 50527

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.3

Temporal Score: 4

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:community_server

Patch Publication Date: 2010/10/11

Vulnerability Publication Date: 2010/11/04

Reference Information

BID: 47871

OSVDB: 68995, 68996, 68997