MySQL Community Server 5.1 < 5.1.52 Multiple Vulnerabilities

medium Nessus Plugin ID 50527
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL Community Server 5.1 installed on the remote host is earlier than 5.1.52 and thus potentially affected by multiple vulnerabilities:

- An error exists in the handling of 'EXPLAIN' for a 'SELECT' statement from a derived table which can cause the server to crash. (54488)

- An error exists in the handling of 'EXPLAIN EXTENDED' when used in some prepared statements, which can cause the server to crash. (54494)

- The server does not check the type of values assigned to items of type 'GeometryCollection'. Such assignments can cause the server to crash. (55531)

Solution

Upgrade to MySQL Community Server 5.1.52 or later.

See Also

https://bugs.mysql.com/bug.php?id=54488

https://bugs.mysql.com/bug.php?id=54494

https://bugs.mysql.com/bug.php?id=55531

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-52.html

Plugin Details

Severity: Medium

ID: 50527

File Name: mysql_5_1_52.nasl

Version: 1.11

Type: remote

Family: Databases

Published: 11/9/2010

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.3

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 10/11/2010

Vulnerability Publication Date: 11/4/2010

Reference Information

BID: 47871

Secunia: 42097