Flash Player < 10.3.181.14 Multiple Vulnerabilities (APSB11-12)

High Nessus Network Monitor Plugin ID 5916

Synopsis

The remote host contains a browser plugin that is affected by a memory corruption vulnerability.

Description

Versions of Flash Player earlier than 10.3.181.14 are potentially affected by multiple vulnerabilities :

- A design flaw exists that could lead to information disclosure. (CVE-2011-0579)
- An integer overflow exists that could lead to code execution. (CVE-2011-0618, CVE-2011-0628)
- Multiple memory corruption issues exist that could lead to code execution. (CVE-2011-0619, CVE-2011-0620, CVE-2011-0621, CVE-2011-0622, CVE-2011-0627)
- Multiple bounds checking issues exist that could lead to code execution. (CVE-2011-0623, CVE-2011-0624, CVE-2011-0625, CVE-2011-0626)

Solution

Upgrade to Flash Player 10.3.181.14 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb11-12.html

Plugin Details

Severity: High

ID: 5916

Family: Web Clients

Published: 2011/05/13

Modified: 2016/01/19

Dependencies: 5783

Nessus ID: 53915, 54299

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2011/05/12

Vulnerability Publication Date: 2011/05/12

Reference Information

CVE: CVE-2011-0589, CVE-2011-0618, CVE-2011-0619, CVE-2011-0620, CVE-2011-0621, CVE-2011-0622, CVE-2011-0623, CVE-2011-0624, CVE-2011-0625, CVE-2011-0626, CVE-2011-0627, CVE-2011-0628

BID: 47806, 47807, 47808, 47809, 47810, 47811, 47812, 47813, 47814, 47815, 47847, 47961