Flash Player for Mac < 10.3.181.14 Remote Code Execution (APSB11-12)

High Nessus Plugin ID 53915

Synopsis

The remote Mac OS X host has a browser plugin that is affected by multiple vulnerabilities.

Description

According to its version, the instance of Flash Player installed on the remote Mac OS X host is earlier than 10.3.181.14. Such versions are reportedly affected by the following vulnerabilities :

- An unspecified information disclosure vulnerability exists. (CVE-2011-0579)

- An unspecified integer overflow vulnerability exists.
(CVE-2011-0618)

- Unspecified memory corruption vulnerabilities exist.
(CVE-2011-0619, CVE-2011-0620, CVE-2011-0621, CVE-2011-0622, CVE-2011-0627)

- Unspecified boundary-checking errors exist.
(CVE-2011-0623, CVE-2011-0624, CVE-2011-0625, CVE-2011-0626)

Solution

Upgrade to Adobe Flash for Mac version 10.3.181.14 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb11-12.html

Plugin Details

Severity: High

ID: 53915

File Name: macosx_flash_player_10_3_181_14.nasl

Version: 1.9

Type: local

Agent: macosx

Published: 2011/05/16

Updated: 2018/07/14

Dependencies: 53914

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/05/12

Vulnerability Publication Date: 2011/05/12

Reference Information

CVE: CVE-2011-0579, CVE-2011-0618, CVE-2011-0619, CVE-2011-0620, CVE-2011-0621, CVE-2011-0622, CVE-2011-0623, CVE-2011-0624, CVE-2011-0625, CVE-2011-0626, CVE-2011-0627

BID: 47806, 47807, 47808, 47809, 47810, 47811, 47812, 47813, 47814, 47815, 47847