Apache Tomcat 7.0.x < 7.0.5 Cross-Site Scripting Vulnerability

Medium Nessus Network Monitor Plugin ID 5793

Synopsis

The remote web server is affected by a cross-site scripting vulnerability.

Description

Versions of Tomcat 7.0.x earlier than 7.0.5 are potentially affected by a cross-site scripting vulnerability because the application uses the user supplied parameters 'sort' and 'orderBy' directly wihtout filtering.

Solution

Upgrade to Apache Tomcat 7.0.5 or later.

See Also

http://tomcat.apache.org/security-7.html

Plugin Details

Severity: Medium

ID: 5793

Family: Web Servers

Published: 2011/02/13

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 51526

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2010/01/01

Vulnerability Publication Date: 2010/11/22

Reference Information

CVE: CVE-2010-4172

BID: 45015