Apache Tomcat 6.x < 6.0.30 / 7.x < 7.0.5 Multiple XSS

Medium Nessus Plugin ID 51526


The remote web server is affected by multiple cross-site scripting vulnerabilities.


According to its self-reported version number, the instance of Apache Tomcat listening on the remote host is 6.x prior to 6.0.30 or 7.x prior to 7.0.5. It is, therefore, affected by multiple cross-site scripting vulnerabilities in the Tomcat Manager application's 'sessionList.jsp' file. The 'sort' and 'orderby' parameters are not properly sanitized before being returned to the user and can be used to inject arbitrary script into the user's browser.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Also note, in the case of Tomcat 7.x, successful exploitation requires that the cross-site request forgery (CSRF) filter is disabled.


Update Apache Tomcat to version 6.0.30 / 7.0.5 or later.

See Also




Plugin Details

Severity: Medium

ID: 51526

File Name: tomcat_7_0_5.nasl

Version: 1.20

Type: combined

Agent: windows, macosx, unix

Family: Web Servers

Published: 2011/01/14

Updated: 2020/03/11

Dependencies: 39446, 130175, 130590

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2010-4172

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2011/01/13

Vulnerability Publication Date: 2010/11/22

Exploitable With

Core Impact

Reference Information

CVE: CVE-2010-4172

BID: 45015

Secunia: 42337

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990