Apache Tomcat 6.0.x < 6.0.28 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5788


The remote web server is vulnerable to multiple attack vectors.


Versions of Tomcat 6.x earlier than 6.0.28 are potentially affected by multiple vulnerabilities :

- The 'WWW-Authenticate' HTTP header for BASIC and DIGEST authentication could potentially expose the local host name or IP adddress of the machine running Tomcat. (CVE-2010-1157)

- Several flaws in handling of the 'Transfer-Encoding' header exist that could prevent the recycling of a buffer. (CVE-2010-2227)


Upgrade to Apache Tomcat 6.0.28 or later.

See Also


Plugin Details

Severity: Medium

ID: 5788

File Name: 5788.prm

Family: Web Servers

Published: 2011/02/11

Modified: 2017/02/02

Dependencies: 3057

Nessus ID: 48255

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2010/07/09

Vulnerability Publication Date: 2010/04/21

Reference Information

CVE: CVE-2010-1157, CVE-2010-2227

BID: 39635, 41544

OSVDB: 64023, 66319

IAVA: 2011-A-0066