Apache Tomcat 6.0 < 6.0.28 Multiple Vulnerabilities

Medium Nessus Plugin ID 48255

Synopsis

The remote Apache Tomcat server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 6.0 listening on the remote host is prior to 6.0.28. It is, therefore, affected by multiple vulnerabilities:

- If a web app is configured to use BASIC or DIGEST authentication and the 'realm-name' attribute is not configured in that web app's 'web.xml' file, the remote server's hostname or IP will be included in replies.
(CVE-2010-1157)

- An error exists in the handling of invalid values in the 'Transfer-Encoding' header of a request. An attacker can exploit this to cause a denial of service or to disclose sensitive information. (CVE-2010-2227)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 6.0.28 or later.

See Also

http://seclists.org/bugtraq/2010/Apr/200

http://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.28

Plugin Details

Severity: Medium

ID: 48255

File Name: tomcat_6_0_28.nasl

Version: 1.21

Type: remote

Family: Web Servers

Published: 2010/08/05

Updated: 2018/08/01

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/07/09

Vulnerability Publication Date: 2010/04/21

Reference Information

CVE: CVE-2010-2227, CVE-2010-1157

BID: 41544

Secunia: 39574