OpenSSL < 0.9.8r / 1.0.0d OCSP Stapling DoS

Medium Nessus Network Monitor Plugin ID 5782


The remote web server is vulnerable to multiple attack vectors.


Versions of OpenSSL earlier than 0.9.8r and 1.0.0d are potentially affected by a vulnerability wherein an incorrectly formatted ClientHello handshake message could cause OpenSSL to parse past the end of the message which could cause the web server to crash. There is also the potential for information disclosure if OCSP nonce extensions are used.


Upgrade to OpenSSL 0.9.8r, 1.0.0d, or later.

See Also

Plugin Details

Severity: Medium

ID: 5782

Family: Web Servers

Published: 2011/02/09

Updated: 2019/03/06

Dependencies: 5563

Nessus ID: 51919

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.4

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2011/02/08

Vulnerability Publication Date: 2011/02/08

Reference Information

CVE: CVE-2011-0014

BID: 46264

IAVA: 2012-A-0148, 2012-A-0153