OpenSSL OCSP Stapling Denial of Service

medium Nessus Plugin ID 51919
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server has an SSL-related denial of service vulnerability.

Description

According to its banner, the remote web server is running a version of OpenSSL older than 0.9.8r or 1.0.0d.

Incorrectly formatted ClientHello handshake messages could cause OpenSSL to parse past the end of the message. This could cause the web server to crash. There is also the potential for information disclosure if OCSP nonce extensions are used.

Solution

Upgrade to OpenSSL 0.9.8r / 1.0.0d or later.

See Also

https://www.openssl.org/news/secadv/20110208.txt

http://cvs.openssl.org/chngview?cn=20359

Plugin Details

Severity: Medium

ID: 51919

File Name: openssl_1_0_0d.nasl

Version: 1.10

Type: remote

Family: Web Servers

Published: 2/9/2011

Updated: 7/16/2018

Dependencies: http_version.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/8/2011

Vulnerability Publication Date: 2/8/2011

Reference Information

CVE: CVE-2011-0014

BID: 46264

Secunia: 43227