OpenSSL OCSP Stapling Denial of Service

medium Nessus Plugin ID 51919


The remote web server has an SSL-related denial of service vulnerability.


According to its banner, the remote web server is running a version of OpenSSL older than 0.9.8r or 1.0.0d.

Incorrectly formatted ClientHello handshake messages could cause OpenSSL to parse past the end of the message. This could cause the web server to crash. There is also the potential for information disclosure if OCSP nonce extensions are used.


Upgrade to OpenSSL 0.9.8r / 1.0.0d or later.

See Also

Plugin Details

Severity: Medium

ID: 51919

File Name: openssl_1_0_0d.nasl

Version: 1.10

Type: remote

Family: Web Servers

Published: 2/9/2011

Updated: 7/16/2018

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/8/2011

Vulnerability Publication Date: 2/8/2011

Reference Information

CVE: CVE-2011-0014

BID: 46264

Secunia: 43227