Exim < 4.74 Local Privilege Escalation Vulnerability

High Nessus Network Monitor Plugin ID 5752

Synopsis

The remote mail server is affected by a local privilege escalation vulnerability.

Description

The remote host is running Exim, a message transfer agent.

Versions of Exim earlier than 4.74 are potentially affected by a local privilege escalation vulnerability. Attackers can exploit this flaw to append arbitrary data to files through symbolic link attacks. Successfully exploiting this issue allows local attackers with 'exim' run-time privileges to perform certain actions with superuser privileges, leading to a complete compromise of an affected computer. Note that this issue only affects Exim on Linux.

Solution

Upgrade to Exim 4.74 or later.

See Also

http://lists.exim.org/lurker/message/20110126.034702.4d69c278.en.html

http://ftp.exim.org/pub/exim/ChangeLogs/ChangeLog-4.74

Plugin Details

Severity: High

ID: 5752

Family: SMTP Servers

Published: 2011/02/01

Updated: 2019/03/06

Dependencies: 2004, 2005

Nessus ID: 51861

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.4

Temporal Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Patch Publication Date: 2011/01/25

Vulnerability Publication Date: 2011/01/25

Reference Information

CVE: CVE-2011-0017

BID: 46065