Exim < 4.74 Local Privilege Escalation

medium Nessus Plugin ID 51861


The remote mail server is potentially affected by a local privilege escalation vulnerability.


The remote host is running Exim, a message transfer agent.

According to the version number in its banner, the installed version of Exim is earlier than 4.74 and thus potentially affected by a local privilege escalation vulnerability.

If the remote host is running Linux, attackers can exploit this issue to append arbitrary data to files through symbolic link attacks.
Successfully exploiting this issue allows local attackers with 'exim' run-time user privileges to perform certain actions with superuser privileges, leading to a complete compromise of an affected computer.


Upgrade to Exim 4.74 or later.

See Also



Plugin Details

Severity: Medium

ID: 51861

File Name: exim_4_74.nasl

Version: 1.10

Type: remote

Published: 2/3/2011

Updated: 7/10/2018

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:L/AC:L/Au:S/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport, SMTP/exim

Exploit Ease: No known exploits are available

Patch Publication Date: 1/25/2011

Vulnerability Publication Date: 1/25/2011

Reference Information

CVE: CVE-2011-0017

BID: 46065