Exim < 4.74 Local Privilege Escalation

medium Nessus Plugin ID 51861
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote mail server is potentially affected by a local privilege escalation vulnerability.

Description

The remote host is running Exim, a message transfer agent.

According to the version number in its banner, the installed version of Exim is earlier than 4.74 and thus potentially affected by a local privilege escalation vulnerability.

If the remote host is running Linux, attackers can exploit this issue to append arbitrary data to files through symbolic link attacks.
Successfully exploiting this issue allows local attackers with 'exim' run-time user privileges to perform certain actions with superuser privileges, leading to a complete compromise of an affected computer.

Solution

Upgrade to Exim 4.74 or later.

See Also

ftp://ftp.exim.org/pub/exim/ChangeLogs/ChangeLog-4.74

https://lists.exim.org/lurker/message/20110126.034702.4d69c278.en.html

Plugin Details

Severity: Medium

ID: 51861

File Name: exim_4_74.nasl

Version: 1.10

Type: remote

Published: 2/3/2011

Updated: 7/10/2018

Dependencies: smtpserver_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:L/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport, SMTP/exim

Exploit Ease: No known exploits are available

Patch Publication Date: 1/25/2011

Vulnerability Publication Date: 1/25/2011

Reference Information

CVE: CVE-2011-0017

BID: 46065