PHP 5.2.x < 5.2.17 / 5.3.x < 5.3.5 String To Double Conversion DoS

Medium Nessus Network Monitor Plugin ID 5740


The remote web server uses a version of PHP that is affected by a denial of service vulnerability.


According to its banner the version of PHP installed on the remote host is either 5.2 earlier than 5.2.17 or 5.3 earlier than 5.3.5. Such versions may experience a crash while performing string to double conversion for certain numeric values. Only x86 32-bit PHP processes are known to be affected by this issue regardless of whether the system running PHP is 32-bit or 64-bit.


Upgrade to PHP version 5.2.17/5.3.5 or later.

See Also

Plugin Details

Severity: Medium

ID: 5740

Family: Web Servers

Published: 2011/01/07

Updated: 2019/03/06

Dependencies: 8682

Nessus ID: 51439

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2011/01/06

Vulnerability Publication Date: 2010/12/30

Reference Information

CVE: CVE-2010-4645

BID: 45668