PHP 5.2 < 5.2.17 / 5.3 < 5.3.5 String To Double Conversion DoS

Medium Nessus Plugin ID 51439

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4


The remote web server uses a version of PHP that is affected by a denial of service vulnerability.


According to its banner, the version of PHP 5.x installed on the remote host is older than 5.2.17 or 5.3.5.

Such versions may experience a crash while performing string to double conversion for certain numeric values. Only x86 32-bit PHP processes are known to be affected by this issue regardless of whether the system running PHP is 32-bit or 64-bit.


Upgrade to PHP 5.2.17/5.3.5 or later.

See Also

Plugin Details

Severity: Medium

ID: 51439

File Name: php_5_3_5.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 2011/01/07

Updated: 2018/11/15

Dependencies: 48243

Risk Information

Risk Factor: Medium

VPR Score: 4.4

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2011/01/06

Vulnerability Publication Date: 2010/12/30

Reference Information

CVE: CVE-2010-4645

BID: 45668