OpenSSL < 0.9.8q / 1.0.0c Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5720

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of OpenSSL earlier than 0.9.8q and 1.0.0c are potentially affected by multiple vulnerabilities :

- It may be possible to downgrade the ciphersuite to a weaker version by modifying the stored session cache cipher suite.

- An error exists in the J-PAKE implementation which could lead to successful validation by someone with no knowledge of the shared secret.

Solution

Upgrade to OpenSSL 0.9.8q, 1.0.0c, or later.

See Also

http://www.openssl.org/news/secadv_20101202.txt

http://seb.dbzteam.org/crypto/jpake-session-key-retrieval.pdf

Plugin Details

Severity: Medium

ID: 5720

Family: Web Servers

Published: 2010/12/07

Updated: 2019/03/06

Dependencies: 5563

Nessus ID: 51058, 51892

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.1

Temporal Score: 5

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2010/12/02

Vulnerability Publication Date: 2010/12/02

Reference Information

CVE: CVE-2010-4180, CVE-2010-4252

BID: 45163, 45164

IAVA: 2011-A-0160, 2012-A-0148, 2012-A-0153