OpenSSL < 0.9.8q / 1.0.0c Multiple Vulnerabilities

High Nessus Plugin ID 51058

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the remote web server is running a version of OpenSSL older than 0.9.8q or 1.0.0c. Such versions are potentially affected by multiple vulnerabilities :

- It may be possible to downgrade the ciphersuite to a weaker version by modifying the stored session cache ciphersuite.

- An error exists in the J-PAKE implementation that could lead to successful validation by someone with no knowledge of the shared secret.

Solution

Upgrade to OpenSSL 0.9.8q / 1.0.0c or later.

See Also

https://www.openssl.org/news/secadv/20101202.txt

http://seb.dbzteam.org/crypto/jpake-session-key-retrieval.pdf

Plugin Details

Severity: High

ID: 51058

File Name: openssl_1_0_0c.nasl

Version: 1.12

Type: remote

Family: Web Servers

Published: 2010/12/07

Updated: 2018/07/16

Dependencies: 10107

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/12/02

Vulnerability Publication Date: 2010/12/02

Reference Information

CVE: CVE-2010-4180, CVE-2010-4252

BID: 45163, 45164

Secunia: 42473