Samba 3.x < 3.5.5 / 3.4.9 / 3.3.14 sid_parse Buffer Overflow

Critical Nessus Network Monitor Plugin ID 5663

Synopsis

The remote Samba server is affected by a buffer overflow vulnerability.

Description

According to its banner, the version of Samba 3.x running on the remote host is earlier than 3.5.5. The 'sid_parse()' and related 'dom_sid_parse()' functions in such versions fail to correctly check their input lengths when reading a binary representation of a Windows SID (Security ID). An attacker who is able to get a connection to a file share, either authenticated or via a guest connection, can leverage this issue to launch a stack buffer overflow attack against the affected smbd service and possibly execute arbitrary code.

Solution

Either apply one of the patches referenced in the project's advisory or upgrade to 3.5.5 / 3.4.9 / 3.3.14 or later.

See Also

https://bugzilla.samba.org/show_bug.cgi?id=7669

http://www.samba.org/samba/security/CVE-2010-2069.html

http://www.samba.org/samba/history/samba-3.5.5.html

http://www.samba.org/samba/history/samba-3.4.9.html

http://www.samba.org/samba/history/samba-3.3.14.html

Plugin Details

Severity: Critical

ID: 5663

Family: Samba

Published: 2010/09/14

Modified: 2016/01/19

Dependencies: 8740

Nessus ID: 49228

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2010/09/14

Vulnerability Publication Date: 2010/09/14

Reference Information

CVE: CVE-2010-3069

BID: 43212