Samba 3.x < 3.5.5 / 3.4.9 / 3.3.14 sid_parse Buffer Overflow

High Nessus Plugin ID 49228

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7

Synopsis

The remote Samba server is affected by a buffer overflow vulnerability.

Description

According to its banner, the version of Samba 3.x running on the remote host is earlier than 3.5.5. The 'sid_parse()' and related 'dom_sid_parse()' functions in such versions fail to correctly check their input lengths when reading a binary representation of a Windows SID (Security ID).

An attacker who is able to get a connection to a file share, either authenticated or via a guest connection, can leverage this issue to launch a stack-based buffer overflow attack against the affected smbd service and possibly execute arbitrary code.

Note that Nessus has not actually tried to exploit this issue or determine if one of the patches has been applied.

Solution

Either apply one of the patches referenced in the project's advisory or upgrade to 3.5.5 / 3.4.9 / 3.3.14 or later.

See Also

https://bugzilla.samba.org/show_bug.cgi?id=7669

https://www.samba.org/samba/security/CVE-2010-3069.html

https://www.samba.org/samba/history/samba-3.5.5.html

https://www.samba.org/samba/history/samba-3.4.9.html

https://www.samba.org/samba/history/samba-3.3.14.html

Plugin Details

Severity: High

ID: 49228

File Name: samba_3_5_5.nasl

Version: 1.12

Type: remote

Family: Misc.

Published: 2010/09/15

Updated: 2018/11/15

Dependencies: 10785

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/09/14

Vulnerability Publication Date: 2010/09/14

Reference Information

CVE: CVE-2010-3069

BID: 43212

Secunia: 41354