Samba 3.x < 3.5.5 / 3.4.9 / 3.3.14 sid_parse Buffer Overflow

high Nessus Plugin ID 49228
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Samba server is affected by a buffer overflow vulnerability.


According to its banner, the version of Samba 3.x running on the remote host is earlier than 3.5.5. The 'sid_parse()' and related 'dom_sid_parse()' functions in such versions fail to correctly check their input lengths when reading a binary representation of a Windows SID (Security ID).

An attacker who is able to get a connection to a file share, either authenticated or via a guest connection, can leverage this issue to launch a stack-based buffer overflow attack against the affected smbd service and possibly execute arbitrary code.

Note that Nessus has not actually tried to exploit this issue or determine if one of the patches has been applied.


Either apply one of the patches referenced in the project's advisory or upgrade to 3.5.5 / 3.4.9 / 3.3.14 or later.

See Also

Plugin Details

Severity: High

ID: 49228

File Name: samba_3_5_5.nasl

Version: 1.12

Type: remote

Family: Misc.

Published: 9/15/2010

Updated: 11/15/2018

Dependencies: smb_nativelanman.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 9/14/2010

Vulnerability Publication Date: 9/14/2010

Reference Information

CVE: CVE-2010-3069

BID: 43212

Secunia: 41354