Flash Player Multiple Vulnerabilities (APSB10-16)

medium Nessus Network Monitor Plugin ID 5625
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a browser plugin that is vulnerable to multiple attack vectors.

Description

Versions of Flash Player 9.x earlier than 9.0.280 and 10.x earlier than 10.1.82.76 are potentially affected by multiple memory corruption issues and a click-jacking vulnerability.

Solution

Upgrade to Flash Player 10.1.82.76 / 9.0.280 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb10-16.html

Plugin Details

Severity: Medium

ID: 5625

Family: Web Clients

Published: 8/12/2010

Updated: 3/6/2019

Dependencies: 5783

Nessus ID: 48300

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*

Patch Publication Date: 8/10/2010

Vulnerability Publication Date: 8/10/2010

Reference Information

CVE: CVE-2010-0209, CVE-2010-2213, CVE-2010-2214, CVE-2010-2215, CVE-2010-2216, CVE-2010-2188

BID: 42358, 42361, 42362, 42363, 40798, 42365