Flash Player < 9.0.280 / 10.1.82.76 Multiple Vulnerabilities (APSB10-16)

high Nessus Plugin ID 48300

Language:

New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Windows host contains a browser plug-in that is affected by multiple vulnerabilities.

Description

The remote Windows host contains a version of Adobe Flash Player 9.x before 9.0.280 or 10.x before 10.1.82.76. Such versions are affected by multiple memory corruption issues and a click-jacking vulnerability.

Solution

Upgrade to Flash Player 10.1.82.76 / 9.0.280 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb10-16.html

Plugin Details

Severity: High

ID: 48300

File Name: flash_player_apsb10-16.nasl

Version: 1.17

Type: local

Agent: windows

Family: Windows

Published: 8/11/2010

Updated: 7/11/2018

Dependencies: flash_player_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Ease: No known exploits are available

Patch Publication Date: 8/10/2010

Vulnerability Publication Date: 8/10/2010

Reference Information

CVE: CVE-2010-0209, CVE-2010-2188, CVE-2010-2213, CVE-2010-2214, CVE-2010-2215, CVE-2010-2216

BID: 40798, 42358, 42361, 42362, 42363, 42364

CERT: 660993