Winamp < 5.58 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5597

Synopsis

The remote host has a media player installed that is vulnerable to multiple attack vectors.

Description

The remote host is running Winamp, a media player for Windows.

Versions of Winamp earlier than 5.58 are potentially affected by multiple vulnerabilities :

- A stack-based buffer overflow when loading a malformed whatsnew.txt file.

- A stack-based buffer overflow when parsing VP6 video content.

An attacker, exploiting these flaws, can execute arbitrary code in the context of the affected application.

Solution

Upgrade to Winamp version 5.58 or later.

See Also

http://www.winamp.com/help/Version_History#Winamp_5.58

http://forums.winamp.com/showthread.php?t=320278

Plugin Details

Severity: Medium

ID: 5597

File Name: 5597.prm

Family: Generic

Published: 2010/07/13

Modified: 2016/01/19

Dependencies: 1735, 8314

Nessus ID: 47717

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/07/13

Vulnerability Publication Date: 2010/07/13

Reference Information

BID: 41591