Winamp < 5.58 Buffer Overflow

High Nessus Plugin ID 47717


The remote Windows host contains a multimedia application that is affected by a stack-based buffer overflow vulnerability.


The remote host is running Winamp, a media player for Windows.

The version of Winamp installed on the remote host is earlier than 5.58. Such versions are reportedly affected by a stack-based buffer overflow vulnerability when parsing VP6 video content. An attacker, exploiting this flaw, can execute arbitrary code in the context of the affected application.


Upgrade to Winamp version 5.58 or later.

See Also

Plugin Details

Severity: High

ID: 47717

File Name: winamp_558.nasl

Version: $Revision: 1.7 $

Type: local

Agent: windows

Family: Windows

Published: 2010/07/14

Modified: 2011/04/13

Dependencies: 15817

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:nullsoft:winamp

Required KB Items: SMB/Winamp/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2010/07/13

Vulnerability Publication Date: 2010/07/13

Reference Information

BID: 41591

OSVDB: 66276