Samba 3.x < 3.3.13 SMB1 Packet Chaining Memory Corruption

critical Nessus Network Monitor Plugin ID 5572
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service is affected by a memory corruption vulnerability.

Description

Versions of Samba 3.x earlier than 3.3.13 are potentially affected by a memory corruption vulnerability when handling specially crafted SMB1 packets. A remote unauthenticated attacker, exploiting this flaw, could crash the affected service or potentially execute arbitrary code subject to the privileges of the user running the affected application.

Solution

Upgrade to Samba 3.3.13 or later.

See Also

http://www.samba.org/samba/security/CVE-2010-2063.html

http://www.samba.org/samba/history/security.html

Plugin Details

Severity: Critical

ID: 5572

Family: Samba

Published: 6/16/2010

Updated: 3/6/2019

Dependencies: 8740

Nessus ID: 47036

Risk Information

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*

Patch Publication Date: 6/16/2010

Vulnerability Publication Date: 6/16/2010

Exploitable With

Metasploit (Samba chain_reply Memory Corruption (Linux x86))

Reference Information

CVE: CVE-2010-2063

BID: 40884