Samba 3.x < 3.3.13 SMB1 Packet Chaining Memory Corruption

high Nessus Plugin ID 47036
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service is affected by a memory corruption vulnerability.

Description

According to its banner, the version of Samba running on the remote host is a version of 3.x before 3.3.13. Such versions are affected by a memory corruption vulnerability when handling specially crafted SMB1 packets.

By exploiting this flaw, a remote, unauthenticated attacker could crash the affected service or potentially execute arbitrary code subject to the privileges of the user running the affected application.

Solution

Upgrade to Samba 3.3.13 or later.

See Also

https://www.samba.org/samba/security/CVE-2010-2063.html

https://www.samba.org/samba/history/security.html

Plugin Details

Severity: High

ID: 47036

File Name: samba_3_3_13.nasl

Version: 1.14

Type: remote

Family: Misc.

Published: 6/17/2010

Updated: 11/15/2018

Dependencies: smb_nativelanman.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/16/2010

Vulnerability Publication Date: 6/16/2010

Exploitable With

Metasploit (Samba chain_reply Memory Corruption (Linux x86))

Reference Information

CVE: CVE-2010-2063

BID: 40884

Secunia: 40145