Samba 3.x < 3.3.13 SMB1 Packet Chaining Memory Corruption

High Nessus Plugin ID 47036

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 7.4


The remote service is affected by a memory corruption vulnerability.


According to its banner, the version of Samba running on the remote host is a version of 3.x before 3.3.13. Such versions are affected by a memory corruption vulnerability when handling specially crafted SMB1 packets.

By exploiting this flaw, a remote, unauthenticated attacker could crash the affected service or potentially execute arbitrary code subject to the privileges of the user running the affected application.


Upgrade to Samba 3.3.13 or later.

See Also

Plugin Details

Severity: High

ID: 47036

File Name: samba_3_3_13.nasl

Version: 1.14

Type: remote

Family: Misc.

Published: 2010/06/17

Updated: 2018/11/15

Dependencies: 10785

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

VPR Score: 7.4

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/06/16

Vulnerability Publication Date: 2010/06/16

Exploitable With

Metasploit (Samba chain_reply Memory Corruption (Linux x86))

Reference Information

CVE: CVE-2010-2063

BID: 40884

Secunia: 40145