PostgreSQL < 8.4.4/8.3.11/8.2.17/8.1.21/8.0.25/7.4.29 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5546

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The remote host is running PostgreSQL earlier than 8.4.4, 8.3.11, 8.2.17, 8.1.21, 8.0.25, or 7.4.29. Such versions are potentially affected by multiple vulnerabilities.

- A vulnerability in Safe.pm and PL/Perl can allow an authenticated user to run arbitrary Perl code on the database server if PL/Perl is installed and enabled. (CVE-2010-1169)

- Insecure permissions on the pltcl_modules table could allow an authenticated user to run arbitrary Tcl code on the database server i PL/Tcl is installed and enabled. (CVE-2010-1170)

- The application does not properly check privileges during certain RESET ALL operations, which could allow a remote authenticated ser to remove arbitrary parameter settings via ALTER USER or ALTER DATABASE statements.

Solution

Upgrade to PostgreSQL 8.4.4, 8.3.11, 8.2.17, 8.1.21, 8.0.25, 7.4.29, or later.

See Also

http://www.postgresql.org/support/security

http://www.postgresql.org/about/news.1203

Plugin Details

Severity: Medium

ID: 5546

Family: Database

Published: 2010/05/18

Modified: 2016/01/21

Dependencies: 8703, 8704

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2010/05/17

Vulnerability Publication Date: 2010/05/17

Reference Information

CVE: CVE-2010-1169, CVE-2010-1170, CVE-2010-1975

BID: 40215, 40304