PostgreSQL < 8.4.4/8.3.11/8.2.17/8.1.21/8.0.25/7.4.29 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 5546
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is vulnerable to multiple attack vectors.


The remote host is running PostgreSQL earlier than 8.4.4, 8.3.11, 8.2.17, 8.1.21, 8.0.25, or 7.4.29. Such versions are potentially affected by multiple vulnerabilities.

- A vulnerability in and PL/Perl can allow an authenticated user to run arbitrary Perl code on the database server if PL/Perl is installed and enabled. (CVE-2010-1169)

- Insecure permissions on the pltcl_modules table could allow an authenticated user to run arbitrary Tcl code on the database server i PL/Tcl is installed and enabled. (CVE-2010-1170)

- The application does not properly check privileges during certain RESET ALL operations, which could allow a remote authenticated ser to remove arbitrary parameter settings via ALTER USER or ALTER DATABASE statements.


Upgrade to PostgreSQL 8.4.4, 8.3.11, 8.2.17, 8.1.21, 8.0.25, 7.4.29, or later.

See Also

Plugin Details

Severity: Medium

ID: 5546

Family: Database

Published: 5/18/2010

Updated: 3/6/2019

Dependencies: 8703, 8704

Nessus ID: 63349

Risk Information


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*

Patch Publication Date: 5/17/2010

Vulnerability Publication Date: 5/17/2010

Reference Information

CVE: CVE-2010-1169, CVE-2010-1170, CVE-2010-1975

BID: 40215, 40304