PostgreSQL 7.4 < 7.4.29 / 8.0 < 8.0.25 / 8.1 < 8.1.21 / 8.2 < 8.2.17 / 8.3 < 8.3.11 / 8.4 < 8.4.4 Multiple Vulnerabilities

high Nessus Plugin ID 63349
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 7.4 prior to 7.4.29, 8.0 prior to 8.0.25, 8.1 prior to 8.1.21, 8.2 prior to 8.2.17, 8.3 prior to 8.3.11 or 8.4 prior to 8.4.4. As such, it is potentially affected by multiple vulnerabilities :

- A vulnerability in Safe.pm and PL/Perl can allow an authenticated user to run arbitrary Perl code on the database server if PL/Perl is installed and enabled.
(CVE-2010-1169)

- Insecure permissions on the pltcl_modules table could allow an authenticated user to run arbitrary Tcl code on the database server if PL/Tcl is installed and enabled. (CVE-2010-1170)

- An unprivileged database user can remove superuser-only settings that were applied to the user's account with ALTER USER by a superuser thus bypassing settings that should be enforced. (CVE-2010-1975)

Solution

Upgrade to PostgreSQL 7.4.29 / 8.0.25 / 8.1.21 / 8.2.17 / 8.3.11 / 8.4.4 or later.

See Also

https://www.postgresql.org/about/news/1203/

https://www.postgresql.org/docs/7.4/release-7-4-29.html

https://www.postgresql.org/docs/8.0/release-8-0-25.html

https://www.postgresql.org/docs/8.1/release-8-1-21.html

https://www.postgresql.org/docs/8.2/release-8-2-17.html

http://www.postgresql.org/docs/8.3/static/release-8-3-11.html

http://www.postgresql.org/docs/8.4/static/release-8-4-4.html

Plugin Details

Severity: High

ID: 63349

File Name: postgresql_20100517.nasl

Version: 1.9

Type: local

Family: Databases

Published: 12/28/2012

Updated: 11/15/2018

Dependencies: postgresql_version.nbin

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 6.3

Vector: AV:N/AC:M/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Ease: No known exploits are available

Patch Publication Date: 5/14/2010

Vulnerability Publication Date: 5/14/2010

Reference Information

CVE: CVE-2010-1169, CVE-2010-1170, CVE-2010-1975

BID: 40215, 40304