OpenSSL < 0.9.8n Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5487


The remote web server is vulnerable to multiple attack vectors.


According to its banner, the remote web server is running a version of OpenSSL older than 0.9.8n. Such versions have the following vulnerabilities :

- Kerberos-enabled versions of OpenSSL do not check the return value when Kerberos configuration files cannot be opened, leading to a crash. (CVE-2010-0433)

- Rejecting a SSL/TLS record with and incorrect version number can lead to a crash. This only affects version 0.9.8m if a 'short' is 1 bits. Otherwise it affects all versions back to and including 0.9.8f. (CVE-2010-0740)


Upgrade to OpenSSL 0.9.8n or later.

See Also

Plugin Details

Severity: Medium

ID: 5487

File Name: 5487.prm

Family: Web Servers

Published: 2010/03/26

Modified: 2017/02/02

Dependencies: 5563

Nessus ID: 45359

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2010/03/24

Vulnerability Publication Date: 2010/03/24

Reference Information

CVE: CVE-2010-0433, CVE-2010-0740

BID: 38533, 39013

OSVDB: 62719, 63299

IAVA: 2011-A-0066