OpenSSL < 0.9.8n Multiple Vulnerabilities

Medium Nessus Plugin ID 45359

Synopsis

The remote web server has multiple SSL-related vulnerabilities.

Description

According to its banner, the remote web server is running a version of OpenSSL older than 0.9.8n. Such versions have the following vulnerabilities :

- Kerberos-enabled versions of OpenSSL do not check the return value when Kerberos configuration files cannot be opened, leading to a crash. (CVE-2010-0433)

- Rejecting a SSL/TLS record with an incorrect version number can lead to a crash. This only affects version 0.9.8m if a 'short' is 16 bits. Otherwise, it affects all versions back to and including 0.9.8f. (CVE-2010-0740)

Solution

Upgrade to OpenSSL 0.9.8n or later.

See Also

https://www.openwall.com/lists/oss-security/2010/03/03/5

https://www.openssl.org/news/secadv/20100324.txt

https://www.openssl.org/news/changelog.html

Plugin Details

Severity: Medium

ID: 45359

File Name: openssl_0_9_8n.nasl

Version: 1.15

Type: remote

Family: Web Servers

Published: 2010/03/26

Updated: 2018/11/15

Dependencies: 10107

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/03/24

Vulnerability Publication Date: 2010/03/24

Reference Information

CVE: CVE-2010-0433, CVE-2010-0740

BID: 38533, 39013

Secunia: 38807

CWE: 20