OpenSSL < 0.9.8m Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5358


The remote host is vulnerable to multiple attack vectors.


According to its banner, the remote host is running a version of OpenSSL older than 0.9.8m. Such versions potentially have the following vulnerabilities :

- Session renegotiations are not handled properly, which could be exploited to insert arbitrary plaintext by a man-in-the-middle. (CVE-2009-3555)

- The library does not check for a NULL return value from calls to the bn_wexpand() function, which has unspecified impact. (CVE-2009-3245)


Upgrade to OpenSSL 0.9.8m or later.

See Also

Plugin Details

Severity: Medium

ID: 5358

File Name: 5358.prm

Family: Web Servers

Published: 2010/03/09

Modified: 2017/02/02

Dependencies: 5563

Nessus ID: 42880, 45039

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 4.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2010/02/25

Vulnerability Publication Date: 2009/11/09

Reference Information

CVE: CVE-2009-3245, CVE-2009-3555

BID: 38562, 36935

OSVDB: 59971, 62844

IAVA: 2011-A-0066