OpenSSL < 0.9.8m Multiple Vulnerabilities

Critical Nessus Plugin ID 45039

Synopsis

The remote web server has multiple SSL-related vulnerabilities.

Description

According to its banner, the remote web server uses a version of OpenSSL older than 0.9.8m. Such versions have the following vulnerabilities :

- Session renegotiations are not handled properly, which could be exploited to insert arbitrary plaintext by a man-in-the-middle. (CVE-2009-3555)

- The library does not check for a NULL return value from calls to the bn_wexpand() function, which has unspecified impact.
(CVE-2009-3245)
- A memory leak in the zlib_stateful_finish function in crypto/comp/c_zlib.c allows remote attackers to cause a denial of service via vectors that trigger incorrect calls to the CRYPTO_cleanup_all_ex_data function.
(CVE-2008-1678, CVE-2009-4355) For this vulnerability to be exploitable, compression must be enabled in OpenSSL for SSL/TLS connections.

Solution

Upgrade to OpenSSL 0.9.8m or later.

See Also

https://rt.openssl.org/Ticket/Display.html?id=2111&user=guest&pass=guest

https://marc.info/?l=openssl-announce&m=126714485629486&w=2

Plugin Details

Severity: Critical

ID: 45039

File Name: openssl_0_9_8m.nasl

Version: 1.17

Type: remote

Family: Web Servers

Published: 2010/03/11

Updated: 2018/11/15

Dependencies: 10107

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/02/25

Vulnerability Publication Date: 2009/11/09

Reference Information

CVE: CVE-2006-4343, CVE-2008-1678, CVE-2009-3245, CVE-2009-3555, CVE-2009-4355

BID: 31692, 36935, 38562

Secunia: 37291, 38200

CWE: 20, 310, 399