OpenSSL < 0.9.8m Multiple Vulnerabilities

critical Nessus Plugin ID 45039


The remote web server has multiple SSL-related vulnerabilities.


According to its banner, the remote web server uses a version of OpenSSL older than 0.9.8m. Such versions have the following vulnerabilities :

- Session renegotiations are not handled properly, which could be exploited to insert arbitrary plaintext by a man-in-the-middle. (CVE-2009-3555)

- The library does not check for a NULL return value from calls to the bn_wexpand() function, which has unspecified impact.
- A memory leak in the zlib_stateful_finish function in crypto/comp/c_zlib.c allows remote attackers to cause a denial of service via vectors that trigger incorrect calls to the CRYPTO_cleanup_all_ex_data function.
(CVE-2008-1678, CVE-2009-4355) For this vulnerability to be exploitable, compression must be enabled in OpenSSL for SSL/TLS connections.


Upgrade to OpenSSL 0.9.8m or later.

See Also

Plugin Details

Severity: Critical

ID: 45039

File Name: openssl_0_9_8m.nasl

Version: 1.17

Type: remote

Family: Web Servers

Published: 3/11/2010

Updated: 11/15/2018

Configuration: Enable paranoid mode

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/25/2010

Vulnerability Publication Date: 11/9/2009

Reference Information

CVE: CVE-2006-4343, CVE-2008-1678, CVE-2009-3245, CVE-2009-3555, CVE-2009-4355

BID: 31692, 36935, 38562

CWE: 20, 310, 399

Secunia: 37291, 38200