Google Chrome < 4.0.249.89 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5336

Synopsis

The remote host contains a web browser that is vulnerable to multiple attack vectors.

Description

The version of Google Chrome installed on the remote host is earlier than 4.0.249.89. Such versions are potentially affected by multiple vulnerabilities :

- Two errors when resolving domain names and when interpreting configured proxy lists can be exploited to disclose sensitive data. (12303, 22914)

- Multiple integer overflows in the V8 engine. (31009)

- An unspecified error when processing the '&lt;ruby&gt;' tag. (31692)

- Chrome leaks redirection targets via the '&lt;iframe&gt;' href. (32309)

- An unspecified error when displaying domain names in HTTP authentication dialogs. (37218)

- An integer overflow when deserializing sandbox messages. (32915)

Solution

Upgrade to Google Chrome 4.0.249.89 or later.

See Also

http://www.nessus.org/u?f0074094

Plugin Details

Severity: Medium

ID: 5336

Family: Web Clients

Published: 2010/02/11

Modified: 2018/09/16

Dependencies: 4645

Nessus ID: 44587

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Patch Publication Date: 2010/02/11

Vulnerability Publication Date: 2010/02/11

Reference Information

CVE: CVE-2010-0315, CVE-2010-0556, CVE-2010-0643, CVE-2010-0644, CVE-2010-0645, CVE-2010-0646, CVE-2010-0647, CVE-2010-0649

BID: 38177