Google Chrome < Multiple Vulnerabilities

High Nessus Plugin ID 44587


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than Such versions are reportedly affected by multiple vulnerabilities :

- Two errors when resolving domain names and when interpreting configured proxy lists can be exploited to disclose sensitive data. (Issue #12303, #22914)

- Multiple integer overflows in the V8 engine.
(Issue #31009)

- An unspecified error when processing the '<ruby>' tag.
(Issue #31692)

- Chrome leaks redirection targets via the '<iframe>' href. (Issue #32309)

- An unspecified error when displaying domain names in HTTP authentication dialogs. (Issue #37218)

- An integer overflow when deserializing sandbox messages.
(Issue #32915)


Upgrade to Google Chrome or later.

See Also

Plugin Details

Severity: High

ID: 44587

File Name: google_chrome_4_0_249_89.nasl

Version: $Revision: 1.16 $

Type: local

Agent: windows

Family: Windows

Published: 2010/02/11

Modified: 2016/11/11

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/02/11

Vulnerability Publication Date: 2010/02/11

Reference Information

CVE: CVE-2010-0315, CVE-2010-0556, CVE-2010-0643, CVE-2010-0644, CVE-2010-0645, CVE-2010-0646, CVE-2010-0647, CVE-2010-0649

BID: 38177

OSVDB: 61792, 62315, 62316, 62317, 62318, 62319, 62320, 62468

Secunia: 38545

CWE: 94, 189, 200, 255