Oracle MySQL < 5.0.88 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5259

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The remote host is running MySQL Community server &lt; 5.0.88. Such versions are potentially affected by multiple issues :

- MySQL clients linked against OpenSSL are vulnerable to man-in-the-middle attacks. (Bug #47320)

- The GeomFromWKB() function can be manipulated to cause a denial of service. (Bug #47780)

- Specially crafted SELECT statements containing sub-queries in the WHERE clause can cause the server to crash. (Bug 48291)

Solution

Upgrade to MySQL Community server 5.0.88 or later.

See Also

http://bugs.mysql.com/bug.php?id=47320

http://bugs.mysql.com/bug.php?id=47780

http://bugs.mysql.com/bug.php?id=48291

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-88.html

Plugin Details

Severity: High

ID: 5259

Family: Database

Published: 2009/12/14

Modified: 2018/09/16

Dependencies: 5003

Nessus ID: 42899

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Patch Publication Date: 2009/11/04

Vulnerability Publication Date: 2009/11/04

Reference Information

CVE: CVE-2009-4019

BID: 37076, 37297