MySQL 5.0 < 5.0.88 Multiple Vulnerabilities

Medium Nessus Plugin ID 42899

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL 5.0 installed on the remote host is earlier than 5.0.88. It is, therefore, potentially affected by the following vulnerabilities :

- MySQL clients linked against OpenSSL are vulnerable to man-in-the-middle attacks. (Bug #47320)

- The GeomFromWKB() function can be manipulated to cause a denial of service. (Bug #47780)

- Specially crafted SELECT statements containing sub- queries in the WHERE clause can cause the server to crash. (Bug #48291)

- It is possible to bypass access restrictions when the data directory contains a symbolic link to a different file system. (Bug #39277)

Solution

Upgrade to MySQL 5.0.88 or later.

See Also

https://bugs.mysql.com/bug.php?id=47320

https://bugs.mysql.com/bug.php?id=47780

https://bugs.mysql.com/bug.php?id=48291

https://bugs.mysql.com/bug.php?id=39277

http://dev.mysql.com/doc/refman/5.0/en/news-5-0-88.html

Plugin Details

Severity: Medium

ID: 42899

File Name: mysql_5_0_88.nasl

Version: 1.17

Type: remote

Family: Databases

Published: 2009/11/25

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/11/04

Vulnerability Publication Date: 2009/11/04

Reference Information

CVE: CVE-2012-4452, CVE-2009-4019, CVE-2009-4028, CVE-2008-7247

BID: 37076, 37297, 38043

Secunia: 37372

CWE: 20, 59