Google Chrome < 3.0.195.33 Security Bypass Vulnerability.

medium Nessus Network Monitor Plugin ID 5234
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is vulnerable to remote code execution attacks.

Description

The version of Google Chrome installed on the remote host is earlier than 3.0.195.33. Such versions are potentially affected by a security bypass vulnerability caused by custom headers being incorrectly sent for 'CORS OPTIONS' requests. A malicious web site operator could set custom HTTP headers on cross-origin 'OPTIONS' requests.

Solution

Upgrade to Google Chrome 3.0.195.33 or later.

See Also

http://www.nessus.org/u?bfb8307e

Plugin Details

Severity: Medium

ID: 5234

Family: Web Clients

Published: 11/13/2009

Updated: 3/6/2019

Nessus ID: 42798

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:*

Patch Publication Date: 11/12/2009

Vulnerability Publication Date: 11/12/2009

Reference Information

CVE: CVE-2009-2816

BID: 36997