Google Chrome < 3.0.195.32 RCE

Medium Nessus Network Monitor Plugin ID 5225

Synopsis

The remote host contains a web browser that is vulnerable to remote code execution attacks.

Description

The version of Google Chrome installed on the remote host is earlier than 3.0.195.32. Such versions are potentially affected by multiple vulnerabilities :

- The user is not warned about certain possibly dangerous file types such as 'SVG', 'MHT', and 'XML' files. In some browsers, JavaScript can execute within these types of files. (23979)

- A malicious site could use the Gears SQL API to put SQL metadata into a bad statement which could cause a subsequent memory corruption. This could lead to a Gears plugin crash or possibly arbitrary code execution. (26179)

Solution

Upgrade to Google Chrome 3.0.195.32 or later.

See Also

http://www.nessus.org/u?1adc32dc

http://www.nessus.org/u?a5c8ae4f

http://googlechromereleases.blogspot.com/2009/11/stable-channel-update_30.html

Plugin Details

Severity: Medium

ID: 5225

Family: Web Clients

Published: 2009/11/06

Modified: 2018/09/16

Dependencies: 4645

Nessus ID: 42413

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Patch Publication Date: 2009/11/05

Vulnerability Publication Date: 2009/11/05

Reference Information

CVE: CVE-2009-3931, CVE-2009-3932, CVE-2009-3933, CVE-2009-3934

BID: 36947