Google Chrome < Multiple Vulnerabilities

High Nessus Plugin ID 42413


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than Such versions are reportedly affected by multiple issues :

- The user is not warned about certain dangerous file types such as 'SVG', 'MHT', and 'XML'. In some browsers, JavaScript can execute within these types of files.
(Issue #23979)

- A malicious site could use the Gears SQL API to put SQL metadata into a bad state, which could cause a subsequent memory corruption which could lead the Gears plugin to crash, or possibly allow arbitrary code execution. (Issue #26179)


Upgrade to Google Chrome or later.

See Also

Plugin Details

Severity: High

ID: 42413

File Name: google_chrome_3_0_195_32.nasl

Version: $Revision: 1.12 $

Type: local

Agent: windows

Family: Windows

Published: 2009/11/06

Modified: 2013/11/13

Dependencies: 34196

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/11/05

Vulnerability Publication Date: 2009/11/05

Reference Information

CVE: CVE-2009-3931, CVE-2009-3932

BID: 36947

OSVDB: 59742, 59743, 59744, 59745

Secunia: 37273

CWE: 20