nginx HTTP Request Header Remote Buffer Overflow

High Nessus Network Monitor Plugin ID 5216

Synopsis

The remote web server is affected by a remote denial of service vulnerability.

Description

The remote host is running a version of nginx web server earlier than 0.5.38, 0.6.39, or 0.7.62. Such versions are potentially affected by a remote denial of service vulnerability because the application fails to to perform adequate bounds checking in the 'ngx_http_process_request_headers()' function of the 'src/http/ngx_http_request.c' source file. An attacker, exploiting this flaw, can cause the web server to crash, or potentially run arbitrary code subject to the privileges of the web server process.

Solution

Apply the patch from the vendor, or upgrade to nginx 0.5.38, 0.6.39, or 0.7.62

See Also

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=552035

Plugin Details

Severity: High

ID: 5216

File Name: 5216.prm

Family: Web Servers

Published: 2009/10/28

Modified: 2016/02/05

Dependencies: 5173

Nessus ID: 41608

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 6.5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:P/RL:O/RC:X

Vulnerability Information

Patch Publication Date: 2009/10/26

Vulnerability Publication Date: 2009/10/26

Reference Information

CVE: CVE-2009-3896

BID: 36839