nginx HTTP Request Multiple Vulnerabilities

High Nessus Plugin ID 41608


The web server on the remote host is affected by multiple vulnerabilities.


The remote web server is running nginx, a lightweight, high performance web server / reverse proxy and email (IMAP/POP3) proxy.

According to its Server response header, the installed version of nginx is affected by multiple vulnerabilities : - A remote buffer overflow attack related to its parsing of complex URIs.

- A remote denial of service attack related to its parsing of HTTP request headers.


Upgrade to version 0.8.15, 0.7.62, 0.6.39, 0.5.38, or later.

See Also

Plugin Details

Severity: High

ID: 41608

File Name: nginx_http_request_buffer_overflow.nasl

Version: $Revision: 1.23 $

Type: remote

Family: Web Servers

Published: 2009/09/24

Modified: 2018/01/29

Dependencies: 106375

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/09/14

Exploitable With


Reference Information

CVE: CVE-2009-2629, CVE-2009-3896

BID: 36384, 36839

OSVDB: 58128, 59278

CERT: 180065

CWE: 119